use strict;
my $str = 'Diagnostics 20200826-12345moretext.zip
Diagnostics 20205839-12345moretext.zip
Diagnostics 20209999-12345moretext.zip
//doesnt start with 2020
Diagnostics 20001212-12345moretext.zip';
my $regex = qr/(?<=2020)\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}