$re = '/(?<=2020)\d{2}/m';
$str = 'Diagnostics 20200826-12345moretext.zip
Diagnostics 20205839-12345moretext.zip
Diagnostics 20209999-12345moretext.zip
//doesnt start with 2020
Diagnostics 20001212-12345moretext.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);