# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)kg.*/\1/gm;t' <<< "2kgminus10meshcomp3kg"