const regex = /(\d+)kg.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)kg.*', 'gm')
const str = `2kgminus10meshcomp3kg`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);