$re = '/(\d+)kg.*/m';
$str = '2kgminus10meshcomp3kg';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;