use strict;
my $str = '2kgminus10meshcomp3kg';
my $regex = qr/(\d+)kg.*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";