import re
regex = re.compile(r"(\d+)kg.*", flags=re.MULTILINE)
test_str = "2kgminus10meshcomp3kg"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)