package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)kg.*`)
var str = `2kgminus10meshcomp3kg`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}