#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)\b(?:(regex101)|(accelerate))\b"
Local $sString = "# Vale Studio " & @CRLF & _
"" & @CRLF & _
"Vale Studio allows you to easily create, test, and debug new rules -- helping you accelerate your development workflow. " & @CRLF & _
"" & @CRLF & _
"Click the "Run" button above to test the rule in left-hand editor on this text. " & @CRLF & _
"" & @CRLF & _
"## Regex101 " & @CRLF & _
"" & @CRLF & _
"```python " & @CRLF & _
"print("Hello, world!") " & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"Vale Studio comes with **built-in** integration with [*regex101*](https://regex101.com/), allowing you to test the regular expression Vale uses after compiling the YAML-based rule."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")