// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)\b(?:(regex101)|(accelerate))\b").unwrap();
let string = "# Vale Studio
Vale Studio allows you to easily create, test, and debug new rules -- helping you accelerate your development workflow.
Click the \"Run\" button above to test the rule in left-hand editor on this text.
## Regex101
```python
print(\"Hello, world!\")
```
Vale Studio comes with **built-in** integration with [*regex101*](https://regex101.com/), allowing you to test the regular expression Vale uses after compiling the YAML-based rule.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}