import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)\\b(?:(regex101)|(accelerate))\\b";
final String string = "# Vale Studio \n\n"
+ "Vale Studio allows you to easily create, test, and debug new rules -- helping you accelerate your development workflow. \n\n"
+ "Click the \"Run\" button above to test the rule in left-hand editor on this text. \n\n"
+ "## Regex101 \n\n"
+ "```python \n"
+ "print(\"Hello, world!\") \n"
+ "```\n\n"
+ "Vale Studio comes with **built-in** integration with [*regex101*](https://regex101.com/), allowing you to test the regular expression Vale uses after compiling the YAML-based rule.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}