using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)\b(?:(regex101)|(accelerate))\b";
string input = @"# Vale Studio
Vale Studio allows you to easily create, test, and debug new rules -- helping you accelerate your development workflow.
Click the ""Run"" button above to test the rule in left-hand editor on this text.
## Regex101
```python
print(""Hello, world!"")
```
Vale Studio comes with **built-in** integration with [*regex101*](https://regex101.com/), allowing you to test the regular expression Vale uses after compiling the YAML-based rule.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}