const regex = new RegExp('(?m)\\b(?:(regex101)|(accelerate))\\b', 'gm')
const str = `# Vale Studio
Vale Studio allows you to easily create, test, and debug new rules -- helping you accelerate your development workflow.
Click the "Run" button above to test the rule in left-hand editor on this text.
## Regex101
\`\`\`python
print("Hello, world!")
\`\`\`
Vale Studio comes with **built-in** integration with [*regex101*](https://regex101.com/), allowing you to test the regular expression Vale uses after compiling the YAML-based rule.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}