using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"config\/info\/(newplan|oldplan|specplan)\/";
string input = @"/config/info/specplan/
/config/info/specplan1/
/config/info/oldplan/
/config/info/newplan/
/config/info/new1plan/
/config/info/newoldplan/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}