package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`config\/info\/(newplan|oldplan|specplan)\/`)
var str = `/config/info/specplan/
/config/info/specplan1/
/config/info/oldplan/
/config/info/newplan/
/config/info/new1plan/
/config/info/newoldplan/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}