re = /config\/info\/(newplan|oldplan|specplan)\//
str = '/config/info/specplan/
/config/info/specplan1/
/config/info/oldplan/
/config/info/newplan/
/config/info/new1plan/
/config/info/newoldplan/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end