const regex = /config\/info\/(newplan|oldplan|specplan)\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('config\\\/info\\\/(newplan|oldplan|specplan)\\\/', 'g')
const str = `/config/info/specplan/
/config/info/specplan1/
/config/info/oldplan/
/config/info/newplan/
/config/info/new1plan/
/config/info/newoldplan/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}