$re = '/config\/info\/(newplan|oldplan|specplan)\//';
$str = '/config/info/specplan/
/config/info/specplan1/
/config/info/oldplan/
/config/info/newplan/
/config/info/new1plan/
/config/info/newoldplan/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);