import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/[\\w.-]+(?<!\\.domain\\.edu)$";
final String string = "https://www.google.com\n"
+ "http://not.the.best.example.org\n"
+ "http://another.bad.example.erewhon.edu\n"
+ "https://my.domain.com\n"
+ "https://your.page.domain.edu\n"
+ "http://good.domain.edu";
final String subst = "https://my.domain.edu";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}