use strict;
my $str = 'https://www.google.com
http://not.the.best.example.org
http://another.bad.example.erewhon.edu
https://my.domain.com
https://your.page.domain.edu
http://good.domain.edu';
my $regex = qr/^https?:\/\/[\w.-]+(?<!\.domain\.edu)$/mp;
my $subst = 'https://my.domain.edu';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";