# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https?:\/\/[\w.-]+(?<!\.domain\.edu)$"
test_str = ("https://www.google.com\n"
"http://not.the.best.example.org\n"
"http://another.bad.example.erewhon.edu\n"
"https://my.domain.com\n"
"https://your.page.domain.edu\n"
"http://good.domain.edu")
subst = "https://my.domain.edu"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.