#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-z]+) (inc|dec) (-?\d+) if ([a-z]+) (.+) (-?\d+)"
Local $sString = "b inc 5 if a > 1" & @CRLF & _
"a inc 1 if b < 5" & @CRLF & _
"c dec -10 if a >= 1" & @CRLF & _
"c inc -20 if c == 10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")