re = /([a-z]+) (inc|dec) (-?\d+) if ([a-z]+) (.+) (-?\d+)/
str = 'b inc 5 if a > 1
a inc 1 if b < 5
c dec -10 if a >= 1
c inc -20 if c == 10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end