import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+) (inc|dec) (-?\\d+) if ([a-z]+) (.+) (-?\\d+)";
final String string = "b inc 5 if a > 1\n"
+ "a inc 1 if b < 5\n"
+ "c dec -10 if a >= 1\n"
+ "c inc -20 if c == 10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}