using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+) (inc|dec) (-?\d+) if ([a-z]+) (.+) (-?\d+)";
string input = @"b inc 5 if a > 1
a inc 1 if b < 5
c dec -10 if a >= 1
c inc -20 if c == 10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}