using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"BE(.*)";
string input = @"BE65J6KN47
BE567800462
B-E6548764543
FR45646864
BF5538765
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}