const regex = /BE(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('BE(.*)', 'gm')
const str = `BE65J6KN47
BE567800462
B-E6548764543
FR45646864
BF5538765
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}