re = /BE(.*)/m
str = 'BE65J6KN47
BE567800462
B-E6548764543
FR45646864
BF5538765
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end