$re = '/BE(.*)/m';
$str = 'BE65J6KN47
BE567800462
B-E6548764543
FR45646864
BF5538765
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);