import re
regex = re.compile(r"BE(.*)", flags=re.MULTILINE)
test_str = ("BE65J6KN47\n"
"BE567800462\n"
"B-E6548764543\n"
"FR45646864\n"
"BF5538765\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")