using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:S32\.(?:\w[25]|[1-35-8]\w)\w\w,?)+|(?:S32\.(?:\w[25]\w|4\w[1346-9])\w,?)+|(?:S32\.(?:\w[25]\w|4\w[235-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[1346-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[235-9])\w,?)+|(?:S72\.(?:[14]\w|9[1346-9])\w\w,?)+|(?:S72\.(?:[14]\w|9[235-9])\w\w,?)+)$";
string input = @"S72.91XB,S72.92XB
S72.211A
S72.414A,S72.415A
S32.509A
S32.301A,S32.821A
S32.421A,S32.422A
S32.421A
S32.421A,S32.509A";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}