use strict;
my $str = 'S72.91XB,S72.92XB
S72.211A
S72.414A,S72.415A
S32.509A
S32.301A,S32.821A
S32.421A,S32.422A
S32.421A
S32.421A,S32.509A';
my $regex = qr/^(?:(?:S32\.(?:\w[25]|[1-35-8]\w)\w\w,?)+|(?:S32\.(?:\w[25]\w|4\w[1346-9])\w,?)+|(?:S32\.(?:\w[25]\w|4\w[235-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[1346-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[235-9])\w,?)+|(?:S72\.(?:[14]\w|9[1346-9])\w\w,?)+|(?:S72\.(?:[14]\w|9[235-9])\w\w,?)+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}