// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:S32\.(?:\w[25]|[1-35-8]\w)\w\w,?)+|(?:S32\.(?:\w[25]\w|4\w[1346-9])\w,?)+|(?:S32\.(?:\w[25]\w|4\w[235-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[1346-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[235-9])\w,?)+|(?:S72\.(?:[14]\w|9[1346-9])\w\w,?)+|(?:S72\.(?:[14]\w|9[235-9])\w\w,?)+)$").unwrap();
let string = "S72.91XB,S72.92XB
S72.211A
S72.414A,S72.415A
S32.509A
S32.301A,S32.821A
S32.421A,S32.422A
S32.421A
S32.421A,S32.509A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}