import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:S32\\.(?:\\w[25]|[1-35-8]\\w)\\w\\w,?)+|(?:S32\\.(?:\\w[25]\\w|4\\w[1346-9])\\w,?)+|(?:S32\\.(?:\\w[25]\\w|4\\w[235-9])\\w,?)+|(?:S72\\.(?:\\w[14]\\w|[0-8]\\w[1346-9])\\w,?)+|(?:S72\\.(?:\\w[14]\\w|[0-8]\\w[235-9])\\w,?)+|(?:S72\\.(?:[14]\\w|9[1346-9])\\w\\w,?)+|(?:S72\\.(?:[14]\\w|9[235-9])\\w\\w,?)+)$";
final String string = "S72.91XB,S72.92XB\n"
+ "S72.211A\n"
+ "S72.414A,S72.415A\n"
+ "S32.509A\n"
+ "S32.301A,S32.821A\n"
+ "S32.421A,S32.422A\n"
+ "S32.421A\n"
+ "S32.421A,S32.509A";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}