import re
regex = re.compile(r"^(?:(?:S32\.(?:\w[25]|[1-35-8]\w)\w\w,?)+|(?:S32\.(?:\w[25]\w|4\w[1346-9])\w,?)+|(?:S32\.(?:\w[25]\w|4\w[235-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[1346-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[235-9])\w,?)+|(?:S72\.(?:[14]\w|9[1346-9])\w\w,?)+|(?:S72\.(?:[14]\w|9[235-9])\w\w,?)+)$", flags=re.MULTILINE)
test_str = ("S72.91XB,S72.92XB\n"
"S72.211A\n"
"S72.414A,S72.415A\n"
"S32.509A\n"
"S32.301A,S32.821A\n"
"S32.421A,S32.422A\n"
"S32.421A\n"
"S32.421A,S32.509A")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")