const regex = /^(?:(?:S32\.(?:\w[25]|[1-35-8]\w)\w\w,?)+|(?:S32\.(?:\w[25]\w|4\w[1346-9])\w,?)+|(?:S32\.(?:\w[25]\w|4\w[235-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[1346-9])\w,?)+|(?:S72\.(?:\w[14]\w|[0-8]\w[235-9])\w,?)+|(?:S72\.(?:[14]\w|9[1346-9])\w\w,?)+|(?:S72\.(?:[14]\w|9[235-9])\w\w,?)+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:S32\\.(?:\\w[25]|[1-35-8]\\w)\\w\\w,?)+|(?:S32\\.(?:\\w[25]\\w|4\\w[1346-9])\\w,?)+|(?:S32\\.(?:\\w[25]\\w|4\\w[235-9])\\w,?)+|(?:S72\\.(?:\\w[14]\\w|[0-8]\\w[1346-9])\\w,?)+|(?:S72\\.(?:\\w[14]\\w|[0-8]\\w[235-9])\\w,?)+|(?:S72\\.(?:[14]\\w|9[1346-9])\\w\\w,?)+|(?:S72\\.(?:[14]\\w|9[235-9])\\w\\w,?)+)$', 'gm')
const str = `S72.91XB,S72.92XB
S72.211A
S72.414A,S72.415A
S32.509A
S32.301A,S32.821A
S32.421A,S32.422A
S32.421A
S32.421A,S32.509A`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}