#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+ +)(AB|DE|RG|DU)"
Local $sString = "23 AB 5400 DE 68 RG" & @CRLF & _
"33 DU 88 DE 8723 AB" & @CRLF & _
"55 RG 76 AB 92 DE"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)