import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+ +)(AB|DE|RG|DU)";
final String string = "23 AB 5400 DE 68 RG\n"
+ "33 DU 88 DE 8723 AB\n"
+ "55 RG 76 AB 92 DE";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}