const regex = /(\d+ +)(AB|DE|RG|DU)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+ +)(AB|DE|RG|DU)', 'gm')
const str = `23 AB 5400 DE 68 RG
33 DU 88 DE 8723 AB
55 RG 76 AB 92 DE`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);