re = /(\d+ +)(AB|DE|RG|DU)/m
str = '23 AB 5400 DE 68 RG
33 DU 88 DE 8723 AB
55 RG 76 AB 92 DE'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result