#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\n([^\|]*?(?:\|[^\|]*?)+?)"
Local $sString = "dsfdqsf" & @CRLF & _
"dsfqds|dsfqds|qfsd|qdf" & @CRLF & _
"dsfqds|dsfqds|qfsd|dqsfq" & @CRLF & _
"dsfqds|dsfqds|qfsd|qdfvqs" & @CRLF & _
"dfq" & @CRLF & _
"" & @CRLF & _
"dsfqds|dsfqds|qfsd|qdf" & @CRLF & _
"dsfqds|dsfqds|qfsd|dqsfq" & @CRLF & _
"dsfqdqs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")