using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n([^\|]*?(?:\|[^\|]*?)+?)";
string input = @"dsfdqsf
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqds|dsfqds|qfsd|qdfvqs
dfq
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqdqs";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}