$re = '/\n([^\|]*?(?:\|[^\|]*?)+?)/';
$str = 'dsfdqsf
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqds|dsfqds|qfsd|qdfvqs
dfq
dsfqds|dsfqds|qfsd|qdf
dsfqds|dsfqds|qfsd|dqsfq
dsfqdqs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);