import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n([^\\|]*?(?:\\|[^\\|]*?)+?)";
final String string = "dsfdqsf\n"
+ "dsfqds|dsfqds|qfsd|qdf\n"
+ "dsfqds|dsfqds|qfsd|dqsfq\n"
+ "dsfqds|dsfqds|qfsd|qdfvqs\n"
+ "dfq\n\n"
+ "dsfqds|dsfqds|qfsd|qdf\n"
+ "dsfqds|dsfqds|qfsd|dqsfq\n"
+ "dsfqdqs";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}