# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?{.*class (\w+)(.*)}$/function $1()$2/gms;t' <<< "package somePackageName
{
class someClassName
{
// other codes
}
}"