use strict;
my $str = 'package somePackageName
{
class someClassName
{
// other codes
}
}';
my $regex = qr/^.*?{.*class (\w+)(.*)}$/msp;
my $subst = 'function $1()$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";