// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)^.*?{.*class (\w+)(.*)}$").unwrap();
let string = "package somePackageName
{
class someClassName
{
// other codes
}
}";
let substitution = "function $1()$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}