$re = '/^.*?{.*class (\w+)(.*)}$/ms';
$str = 'package somePackageName
{
class someClassName
{
// other codes
}
}';
$subst = "function $1()$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;