package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)^.*?{.*class (\w+)(.*)}$`)
var str = `package somePackageName
{
class someClassName
{
// other codes
}
}`
var substitution = "function $1()$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}