using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?{.*class (\w+)(.*)}$";
string substitution = @"function $1()$2";
string input = @"package somePackageName
{
class someClassName
{
// other codes
}
}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}